Your Cart

Main image doesn’t load in IE 10 with document mode IE 7 standards

These forums are now closed to new replies / tickets.

Please open a support ticket from our new Support page.

Front Page Forums Problems Main image doesn’t load in IE 10 with document mode IE 7 standards

  • gravatar
    Will
    January 8, 2013 at 12:02 pm

    Hi,

    I’m testing my galleria at the moment, I have both the classic
    and twelve theme and testing it in IE 10 (and then changing it in
    developers tools to use “Document mode: IE 7 standards”).

    In both themes, it seems the main photo doesn’t show and the
    number of photos says “- / 3”.

    However the thumbnails works and shows the photos.

    I then updated my base JS file from galleria-1.2.7.js to
    galleria-1.2.8.js, and also updated the classic theme, but it still
    didn’t work.

    Which lead me to think it might be my codes. So I tested your
    site using IE 10 with document mode IE7, but your site works
    fine!

    Did you put some fix for this? or do you know how I can fix
    it.

    Any help would be very much appreciated.

    Many thanks,

    Will

    Attachments:
    1. Untitled1
    2. Untitled2


    gravatar
    Will
    January 8, 2013 at 12:04 pm

    Also just to confirm, my gallery works fine on all browser and
    in all IE versions, including IE10, but only when the document mode
    is “IE7 standards”, it doesn’t work.


    gravatar
    Will
    January 10, 2013 at 3:15 pm

    Hi all,

    I have found out the reason why the gallery doesn’t work in IE10
    (with document mode as “IE 7 standards”).

    It is because the anchor that surrounds each image did not have
    a “href” set.

    I had infact actually coded my ASP.NET repeater to add the
    anchor href, but decided to comment it out, because I thought it
    was optional, since it works in all browser and modes apart from
    the combination above!

    Hopefully this helps anyone who had similar issues.

    Cheers,

    Will


    gravatar
    Will
    January 10, 2013 at 3:17 pm

    Out of interest, do any of the developers know why this is
    needed? or the reason for it break in the combination above?


Galleria uses cookies to provide necessary site functionality. By using our website, you agree to our Privacy Policy. I understand